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1 Introduction to Using Excel Spreadsheets

This section of the guide is based on the file (a faux grade sheet created for messing with):
http://personal.morris.umn.edu/∼mcquarrb/teachingarchive/M1001/excel/ExcelIntro.xlsx

Important: Download the file to the desktop before you begin to work with it. If you open it while it is still “online”,
some of the Excel functions I refer to later will be disabled. This is just meant to get us comfortable with Excel, we will
get more practice in class and on assignments throughout the semester. You may have to click Enable Editing once you
open the file.

A Note About Data Security

Save your work often, since things sometimes go wrong. It’s a good idea to have a backup copy of really important work,
or work that would take a lot of time to recreate. In Excel, you can save your work by clicking the disk image on the Quick

Access Toolbar in the top left of the window. Before you leave a public computer, make sure you take your
work with you on a portable disk, and/or email the work to yourself so you have a copy.

Equally important to is to delete any work that has been saved to the desktop when you leave. Delete, and empty the trash.
It has happened that a student left work on a public computer, and another student came along and used this work for
an assignment–the first student (whose only crime was not being diligent about securing his intellectual property) had to
deal with the fallout from an academic integrity violation when the instructor graded the assignments.

Changing Font

You can change the font on an individual cell if you like. Let’s change the font for the entire spreadsheet. You can do that
by first selecting all the cells in the spreadsheet, which is accomplished by clicking on the corner rectangle, which is the
rectangle to the left of A and above 1. Once you have selected all the cells, change the font face and size by selecting from
the Menu bar the Home > Font. Alternately, you can right click on a region you selected to get options for formatting.

Changing Formatting Options for Row 1

The first row can be selected by left clicking on the 1. Once you have selected the first row, you can adjust the format
of it. Right click anywhere in the selected region, choose Format Cells, and see what can be changed from the Format
Cells dialog box. You can change the format of the number, text alignment, font, patterns (background colour), among
other things. Other than choosing Format Cells, you can use the small dialog box that pops up when you right click on
a region to make some changes to the formatting.

Undo

If you don’t like a change you made, you can undo it by clicking the undo button on the Quick Access Toolbar on the
top left of the page. You can undo multiple times.

Changing Width of Columns & Rows

If you changed the text earlier, you may have a cell that is too small to contain the text. You can adjust the width of
columns or rows by right clicking the column or row heading and then selecting either Column Width or Row Height.
You can also adjust a single column width if you hover your curser between column headings (similar for rows).

Working with Sheets

Excel files can have more than one Sheet. This file has one Sheet, titled Grades (at the bottom of the window). You can
change the name of the sheet by right clicking on the Worksheet Tab Grades and selecting Rename. You can also copy
and paste sheets at this point. Try it!

http://personal.morris.umn.edu/~mcquarrb/teachingarchive/M1001/excel/ExcelIntro.xlsx
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Relative Cell Reference: Sum, Copy, Paste

OK, let’s do something useful with the data. To sum the potential grades a student can earn, we should enter a formula
in cell K2. To enter a formula or data into a cell you first left click on the cell. You can also type the cell reference you
wish to work with in the Name Box, and the active cell will move to that cell.

The formula we want should tell Excel to sum the entries from cell B2 to J2. This is done by typing

=sum(B2:J2)

This should be evaluated and give 525 in cell K2. Notice the formula appears in the Formula Bar, but it is the value of
the evaluated formula that appears in the active cell in the spreadsheet. Also notice when you select a cell with a formula
Excel highlights the cells being used in the formula.

We want this sum for all the students, but we don’t want to type this for each student. Instead, we can copy and paste
the formula from cell K2, and Excel will adjust the formula to have the correct form for each row! How cool is that?
The answer is very cool, of course. Once you start cutting and pasting formulas in Excel it becomes an extremely useful
program. Here’s how we do it:

Right click on cell K2, and select Copy.
Use the mouse to select cells K3 to K16 (left click, hold, and drag).
Right click anywhere in the group of cells you just selected, and select Paste.

You should have the totals for all students now. What has happened here is Excel has used relative cell references, and
adjusted each formula to be the correct formula depending on what row the formula is in. If you click on cell K9, you will
see the formula in the Formula Bar is =SUM(B9:J9).

Another way to copy is to highlight the cell you want to copy, and hold left click the small black square at the lower
right of the cell. You can now drag the cell and it will be copied. This is a useful technique if you want to copy a cell
down a column, or across a row.

Absolute Cell Reference

If we want a final percentage grade for each student, we want to divide each student’s total grade by 525 (the total possible).

To get started, we should work on the total for Chris. We want 357/525, but we want to enter this in a way that if we
change the grade Chris received on an assignment we wouldn’t have to adjust the formula here as well. You might think
entering in cell L3 something like K3/K2 would work, but you will find it won’t. Anytime we enter a formula we need to
tell Excel that is going to calculate something, and we do that with an equal sign. So we should enter

=K3/K2

This will work for Chris, but remember the power of Excel is when we can copy and paste formulas and have them work
elsewhere. Copy and paste cell L3 into L4, and see what happens. Yikes! Deb scored 1.241 (124%!), which is clearly wrong.

The problem is that we need an absolute cell reference for the cell K2. When we copy and paste the formula we create in
cell L3 to cell L4, we want the K3 value to change to L4 but the K2 to remain as K2.

We can modify our formula in cell L3 so this will happen.

=K3/$K$2

If we copy and past this formula to a different row, Excel will adjust the K3 to the correct cell for that row, but will always
divide by the value in cell K2. The dollar signs make this an absolute cell reference.
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Formatting Cells to Represent Percentages or Money (Currency)

Cells can automatically be formatted as a percentage, or include a dollar sign if the cell value represents money. Select the
cell or cells that you want to represent as a percentage (column L). From the Menu Bar, click the arrow at the bottom right
of the Home > Number box (it may already be open). This brings up the Format Cells dialog box (or, you can right
click the cells you selected and choose Format Cells). From the Number tab select percentage. If the cell represents
currency, from the Number tab select currency. You can also increase or decrease the number of decimals shown.

Delete, Insert

You can delete or insert rows or columns. Let’s delete Geri from the class. Right click on the 6 beside Geri to select the
entire row associated with her. You can choose to copy this row, delete this row, or insert a row here. Select Delete and
the row will be removed, the rows below shifting up. If you decide you deleted Geri by mistake, you can undo it by clicking

the undo button on the Quick Access Toolbar on the top left of the page.

Paste

Paste can be tricky in Excel, since sometimes you want to paste a formula, and sometimes you want to paste the number
that formula gives you. By default, Excel will try to paste the formula. If you want to paste the number, you need to
choose Paste Special.

Select cell L8, which on the spreadsheet is a number but in the Formula Bar contains a formula. Try to copy and paste
into cell C19 and see what happens. From the pop-up you can choose to paste values, formulas, formatting, and other.
You should experiment a bit with what each does.

Showing the Formulas

Sometimes it can be useful to have Excel show all the formulas in the spreadsheet, rather than what they evaluate to (this
can be useful if you have an error somewhere and don’t know where it is). To have Excel show you the formulas, hold
down Ctrl ` (control, accent) all at once. To switch back to showing the evaluation of the formulas, hold down Ctrl `
again. Try it! Notice that the widths of the columns will change, so you might have to scroll over to see the formulas.

Sort

You can sort the data by the value in a particular column if you like. Select rows 3 through 16 (all the students). Then,
from the Menu Bar choose Data > Sort. This launches the Sort dialog box. Make sure the box beside “my data has
headers” is unchecked (your data does have headers, but we haven’t selected them). If you choose to sort by Column A,
the data with be alphabetized by student. If you choose to sort by Column L, the data will be sorted by student grade.

Freezing Panes

From the Menu Bar, choose View > Window (Freeze Panes) and see what that does. This is very useful if you have
large data sets to manipulate, and you want to always see the row and column labels. Freeze Panes will freeze above
and to the left of the selected cell, so you can scroll both to the right and down and maintain headings.

Comment Boxes in Excel

The Drawing Tools is used to add a box to a spreadsheet which you can write comments in. From the Menu Bar, choose
Insert > Illustrations (Shapes) to see what options are available. Select a shape, then left click on the spreadsheet
to place the shape, which can then be resized and to which you can add text. This provides a convenient way of adding
explanation to a spreadsheet.

Once you have the shape in the spreadsheet, left click on the shape and the Shape Styles tool will appear in the Menu
Bar. You can use this to modify the shape. Try it! If you have added some text to the shape, you can right click on the
text and choose font to modify the size of the font.
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2 Analyzing Data Using Excel

Dates in Excel

The date January 1, 2013 can be entered in Excel using the formula =DATE(2013,1,1).

This is a great benefit in personal finance problems, because you can then add 1 month to this date using the formula
=DATE(2013,1+1,1) which will yield February 1, 2013.

You can add 4 months using =DATE(2013,1+4,1), which yields May 1, 2013.

To add 1 day to the date, and get an output of January 2, 2013, you can enter the formula =DATE(2013,1,1+1). In a
similar fashion you can get any date you want from the initial date. If you add 12 months to a date, the year will increment
by one, so =DATE(2013,1+12,1) will yield January 1, 2014.

Here is one way (there are others) that you can conveniently enter dates in Excel, when the dates are changing in the
month. This would be useful in a problem where interest was being compounded monthly. This way is convenient because
you can copy/paste to get more dates!

A B
1 Compounding Period Date
2 0 =DATE(2013,1,1)
3 1 =DATE(2013,1+A3,1)
4 2 =DATE(2013,1+A4,1)

Once you have the formulas in Excel, you can format how the date is presented. After selecting the cells that represent
dates, Right click anywhere in the selected region, choose Format Cells, and from the Number tab then select date.

Importing Data Into Excel

Getting data into Excel can be a bit tricky, but it is important if you hope to be able to analyse data effectively using
Excel. Here is an outline of how you can do it.

I have some data at http://personal.morris.umn.edu/∼mcquarrb/teachingarchive/M1001/excel/data1.txt that you can
download into Excel. First try a simple copy/paste and see what goes wrong.

An easy way to paste delimited data into Excel is the following. Select and copy the data you wish to save. Click on
the cell where you want to start pasting the data, then left click and choose Paste Special. Choose text. Now,
click on the clipboard image Excel has placed beside the newly pasted text, and choose Use Text Import Wizard.
Follow the steps to get the data aligned correctly in the cells.

If the above doesn’t work, you can always do the following:
• Store the Data in a text file such as data.txt as comma delimited text, or tab delimited text.

You can use Notepad or some other editor to do this, and can copy and paste the data from a webpage.
• In Excel, choose from the drop down menu Data > From Text. You will have some choices to make, so make the

appropriate choices based on how you stored the data in the text file. You can view how the data will be imported
into Excel at this stage.

Formatting Charts

In Excel, rarely are the default options for a chart either pleasing to the eye or the best way to convey information. You
should always include axes labels, include a title, remove unnecessary legends, and change grid lines and other parts of the
chart to make it easy to understand and (frankly) enjoyable to look at.

XY Plots

To do linear regression (and nonlinear regression as well) and determine the correlation r between two variables, we can
first create a scatterplot of the data, and then get Excel to figure out the equation of the regression line and the correlation
from the scatterplot. Let’s treat the data you pasted into Excel as (x, y) pairs, and create a scatterplot for the data using
the following process.

http://personal.morris.umn.edu/~mcquarrb/teachingarchive/M1001/excel/data1.txt
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Creating a Scatterplot

Here is one way you can create a scatterplot in Excel.

• First, highlight the data you want in your scatterplot. You can remove or add data later, so feel free to highlight
more than you need. If your data is not in two columns that are beside each other, start a new sheet and put the
data in two columns side-by-side–it’s just a whole lot easier if it’s like this!

• From the Menu Bar select Insert > Charts. Choose Scatter to get the scatter plot. You can choose to have
only points, points connected by lines, etc. Once the chart is created, you can modify it, so the choice you make here
isn’t very important. Choose only the points, since we will be putting a regression line on the plot later.

• Once the chart is created, left click on it and the Menu Bar will change to give you options to change the layout,
data, and other things in your chart. If you choose a layout with titles (and you should!) you can double click on the
titles to change them.

You can move the scatterplot around in the sheet once it has been created. If you click on the chart to make it active, you
will get a dialog that allows you to change things (clicking different parts of the chart brings up different dialogs). From
this dialog you can change your chart, and add things to the chart. If you spent time earlier thinking about what you want
in your chart, the only thing you will want to add at this time is a regression line and the correlation, but other changes
are possible. You can also double click on the chart itself to make changes (sometimes you need to change the format of
the data points, which you can do by double clicking on the data points). You can even change the source data that is
being plotted if you like. You can also drag a corner of the chart to change its size.

Adding Regression Line and Correlation to Scatterplot

The easiest way to add a linear regression line to a scatterplot is to to choose a layout that automatically includes the
linear trendline in the scatterplot, such as Layout 9.

Once you have a plot of the data, right click on the data points and you will get some options. Choose Add Trendline.
Choose linear, then click the tab options and check the boxes next to Display equation and Display R-squared
value. Click Close. Notice that this is how you can add other types of trendlines beyond linear.

You can move the equation to another part of the chart if you like.

You should find that y = 0.501x+1.6686 and R2 = 0.4911. The R2 is the square of the correlation r, and with the equation
of the linear regression line you are able to make predictions of future behaviour of the variables.

Formulas

I’ve assumed the data x1, x2, x3, x4 is stored in cells A1, A2, A3, A4. Vary the ranges in the Excel formula for the
data you are working with.

Statistical Quantity Mathematical Formula Excel Formula

mean x̄ = 1
4

∑4
i=1 xi =average(A1:A4)

standard deviation s =
√

1
3

∑4
i=1(xi − x̄)2 =stdev(A1:A4)

variance s2 =var(A1:A4)

median =median(A1:A4)
first quartile =quartile(A1:A4,1)
third quartile =quartile(A1:A4,3)
maximum =max(A1:A4)
minimum =min(A1:A4)

Boxplots

These are more than a bit tricky to create in Excel, although getting the five-number summary that is used to create them
is easy! If you are interested, Google for examples of how to create Boxplot in Excel 2007; for this class you can use Excel
to get the five number summary and then draw the boxplots neatly by hand.
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Analysis Toolpack

There is an add-in called the Analysis Toolpack for Excel that can really help with statistical analysis, but it is not always
installed. Everything we have done so far has not used the Analysis Toolpack. The toolpack gives you access to even more
statistical tools than these. We will use it mainly for creating Histograms.

You can see if the version of Excel you are working with has the toolpack installed by going to the Menu Bar and selecting
Data. The Analysis options should be available. If it is not, you can add it in by doing the following:

• Left click File in Menu Bar
• Choose “Options” down near the bottom
• Choose “Add-Ins”
• Choose “Go” near the bottom
• Select Analysis Toolpack, click OK and you’re done! The Analysis Toolpack should now be installed.

Histograms with Analysis Toolpack

Warning! A histogram is a column chart, but a column chart is not a histogram! If you simply try to create a
histogram by selecting the data and using Insert > Charts (Column) you will not get a histogram!

Let’s construct histograms of the following two datasets:
http://umn.edu/∼mcquarrb/teachingarchive/M1001/excel/data2.txt. We will do this using the tools from the Analysis
toolpack. First, Download the data sets into Excel. I put them in columns A and B.

We need to decide what our bounding boxes will be for the histogram we will create. Say we want intervals from 0-20,
20-40, 40-60, 60-80, 80-100. We need to make a list of the upper numbers in the bins in a column. In cell D1, type the
heading Interval, and then put in D2 the number 20, D3 40, D4 60, D5 80, D6 100. It should look like this when you
are done:

A B C D
1 85.22 58.5 Interval
2 11.31 99.55 20
3 5.864 25.14 40
4 9.703 26.39 60
5 28.81 24.99 80
6 3.518 49.01 100

To generate the histogram, from the Menu Bar go to Data > Data Analysis and select Histogram.

The Input Range should be the data you want the histogram for.

To select the data values to plot, click on the small image of a spreadsheet to the right of the box beside Input Range.
The window will collapse to a line, and you can now select the distribution you want the histogram for (you can even select
the distribution from another sheet in the Excel file). When you have selected the correct values, click on the small image
of a spreadsheet, and the cell references will be placed into the box. You could type the cell reference by hand, but this
process is usually easier.

The Bin Range is the list of values you just entered in D2:D6. Use the process described above to select the Bin Range.

Output Range allows you to choose where the Bin/Frequency data and histogram should be placed.

Make sure you check Chart Output to get the chart!

If you don’t like the gap betweens the bars in your histogram, you can set the gap width to zero. Click on the histogram
bars and choose Format Data Series. Under Options you can set the gap width to zero. If you remove the gap, you will
probably also want to change the border color to make the rectangles stand out more clearly.

You can get rid of the More Data by clicking on a bar in the chart and then dragging the Bin/Frequency data in the
spreadsheet (notice it is highlighted when you click on the chart) so it does not include the More category. You can also
remove the Legend, since it is not very useful most of the time. Just click on the legend and choose Delete.

http://umn.edu/~mcquarrb/teachingarchive/M1001/excel/data2.txt
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